79 lines
1.8 KiB
Nix
79 lines
1.8 KiB
Nix
{
|
|
flake,
|
|
inputs,
|
|
outputs,
|
|
lib,
|
|
config,
|
|
modulesPath,
|
|
...
|
|
}: {
|
|
imports =
|
|
[
|
|
(modulesPath + "/installer/scan/not-detected.nix")
|
|
inputs.disko.nixosModules.disko
|
|
flake.diskoConfigurations.standard
|
|
inputs.hardware.nixosModules.lenovo-thinkpad-x1-yoga
|
|
]
|
|
++ (with outputs.nixosModules; [
|
|
desktop-usage
|
|
gnome
|
|
wifi
|
|
]);
|
|
|
|
nixpkgs = {
|
|
overlays = [
|
|
outputs.overlays.additions
|
|
outputs.overlays.modifications
|
|
outputs.overlays.unstable-packages
|
|
];
|
|
config = {
|
|
allowUnfree = true;
|
|
};
|
|
};
|
|
|
|
nix = {
|
|
registry = lib.mapAttrs (_: value: {flake = value;}) inputs;
|
|
nixPath = lib.mapAttrsToList (key: value: "${key}=${value.to.path}") config.nix.registry;
|
|
|
|
settings = {
|
|
experimental-features = "nix-command flakes";
|
|
auto-optimise-store = true;
|
|
};
|
|
};
|
|
|
|
# not necessarily "base", but all my machines are UEFI so...
|
|
boot.loader.systemd-boot.enable = true;
|
|
|
|
services.fprintd = {
|
|
enable = true;
|
|
# tod.enable = true;
|
|
# tod.driver = pkgs.libfprint-2-tod1-goodix;
|
|
};
|
|
|
|
environment.systemPackages =
|
|
#with pkgs;
|
|
[];
|
|
|
|
programs.steam.enable = true;
|
|
programs.steam.remotePlay.openFirewall = true;
|
|
|
|
networking = {
|
|
firewall = {
|
|
enable = true;
|
|
allowPing = true;
|
|
allowedTCPPorts = [22];
|
|
allowedUDPPorts = [];
|
|
};
|
|
};
|
|
|
|
boot.initrd.availableKernelModules = ["xhci_pci" "nvme" "usb_storage" "sd_mod"];
|
|
boot.initrd.kernelModules = [];
|
|
boot.kernelModules = ["kvm-intel"];
|
|
boot.extraModulePackages = [];
|
|
|
|
networking.useDHCP = lib.mkDefault true;
|
|
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
|
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
|
|
system.stateVersion = "23.11";
|
|
}
|