foxtrot-nix/flake.nix

90 lines
2.7 KiB
Nix

{
inputs = {
lytedev.url = "git+https://git.lyte.dev/lytedev/nix";
};
outputs = {lytedev, ...}: let
system = "x86_64-linux";
overlay = final: prev: {
final = {
linux_6_5 = {
patches = [];
kernelPatches = [];
};
};
linux_6_5 = prev.linux_6_5.override {
patches = [];
kernelPatches = [];
};
};
pkgs = lytedev.inputs.nixpkgs-unstable.legacyPackages."x86_64-linux".extend overlay;
in {
nixosConfigurations.live = lytedev.inputs.nixpkgs-unstable.lib.nixosSystem {
inherit system;
modules = [
(lytedev.inputs.nixpkgs-unstable + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
{
boot.supportedFilesystems =
pkgs.lib.mkForce ["btrfs" "cifs" "f2fs" "jfs" "ntfs" "reiserfs" "vfat" "xfs"];
boot.kernelPatches = pkgs.lib.singleton {
name = "no";
patch = null;
extraConfig = ''
'';
};
boot.kernelPackages = pkgs.linuxPackagesFor (
pkgs.linux_6_5.override {
argsOverride = {
src = pkgs.fetchurl {
url = "https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.5.7.tar.xz";
sha256 = "sha256-DQnqRIAFyc/lOD5Mcqhys5GIuSj4xE4UawOxt4Ufu4w=";
};
version = "6.5.7";
modDirVersion = "6.5.7";
};
}
);
}
];
};
# Standalone home-manager configuration entrypoint
# Available through 'home-manager --flake .#your-username@your-hostname'
homeConfigurations = {
# TODO: non-system-specific home configurations?
"foxtrot" = let
system = "x86_64-linux";
in
lytedev.inputs.home-manager.lib.homeManagerConfiguration {
pkgs = lytedev.inputs.nixpkgs-unstable.legacyPackages.${system};
extraSpecialArgs = {
inherit (lytedev) outputs inputs colors font;
inherit system;
};
modules = with lytedev.outputs.homeManagerModules; [sway sway-laptop];
};
};
diskoConfigurations = import ./disko;
};
nixConfig = {
extra-experimental-features = ["nix-command" "flakes"];
extra-substituters = [
"https://cache.nixos.org/"
"https://helix.cachix.org"
"https://nix-community.cachix.org"
"https://nix.h.lyte.dev"
];
extra-trusted-public-keys = [
"cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY="
"helix.cachix.org-1:ejp9KQpR1FBI2onstMQ34yogDm4OgU2ru6lIwPvuCVs="
"nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
"h.lyte.dev:HeVWtne31ZG8iMf+c15VY3/Mky/4ufXlfTpT8+4Xbs0="
];
};
}